Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007161 [DCSS] Bug Report minor sometimes 2013-06-05 08:26 2013-06-05 20:32
Reporter qoala View Status public  
Assigned To DracoOmega
Priority normal Resolution done Local or Remote Remote
Status resolved   Operating System CSZO
Projection none   Console or Tiles Console
ETA none Fixed in Branch 0.13 ancient branch Product Branch 0.13 ancient branch
  Product Version 0.13-a0-1358-g20c23f8
Summary 0007161: Lamp of Fire: Range Check Error
Description A friend of mine (CSZO account: rubinko) has repeatedly been getting a crash involving the lamp of fire in Sprint. He has a number of each elemental evoker and frequently uses the lot of them for hard fights (perhaps their recharge should be reduced in sprint, but that's separate), but every so often when a lamp of fire is evoked the game crashes. He's using them often, so it seems to only effect the lamp. It doesn't happen every time, but after 8 crashes, it seems his save is well setup to test the bug if one simply runs around spamming the elemental evokables.

The error shown in ##crawl-dev logs is:
"rubinko (L15 SpEn) ERROR: range check error (-1 / 80) (D (Sprint))"

He backed up his sprint save on CSZO. (Due to spotty autosaving in sprint, item and monster placement has largely reset while leaving his inventory intact, but that's unrelated)
All 8 crash logs at http://dobrazupa.org/morgue/rubinko/ [^] are related.
Steps To Reproduce
Additional Information
Tags has patch
Attached Files ? file icon lampofire_bounds.patch [^] (1,985 bytes) 2013-06-05 11:00 [Show Content]

- Relationships

-  Notes
(0023062)
qoala (reporter)
2013-06-05 11:05

DracoOmega suggested on irc that this is due to the jitter path picking points outside the map bounds when firing the lamp of fire near the boundary.

I've confirmed this, and attached a patch which uses clamp_in_bounds to keep the randomly generated points inside the map. Could also have just vetoed random offsets that led to illegal points, but this should result in less tries before succeeding.

The paths look oddly skewed when firing at the map boundary, but I don't think it's any more odd than the results of firing at any other wall at mid-close range.

Should probably let DracoOmega confirm that after the patch the lamp still behaves as intended.
(0023070)
DracoOmega (developer)
2013-06-05 20:32

I have tested and applied the patch. Thanks!

- Issue History
Date Modified Username Field Change
2013-06-05 08:26 qoala New Issue
2013-06-05 11:00 qoala File Added: lampofire_bounds.patch
2013-06-05 11:05 qoala Note Added: 0023062
2013-06-05 16:46 mumra Tag Attached: has patch
2013-06-05 20:32 DracoOmega Note Added: 0023070
2013-06-05 20:32 DracoOmega Status new => resolved
2013-06-05 20:32 DracoOmega Fixed in Branch => 0.13 development branch
2013-06-05 20:32 DracoOmega Resolution open => done
2013-06-05 20:32 DracoOmega Assigned To => DracoOmega


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker