Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006877 [DCSS] Bug Report major have not tried 2013-04-05 10:40 2013-04-08 18:53
Reporter Mandevil View Status public  
Assigned To mumra
Priority normal Resolution done Local or Remote Remote
Status resolved   Operating System CSZO
Projection none   Console or Tiles Console
ETA none Fixed in Branch 0.13 ancient branch Product Branch 0.12 ancient branch
  Product Version 0.12-b1-58-g4e74d03
Summary 0006877: Going from Ice Form while Hungry with wielded vampiric weapon results in instadeath
Description It seems that when you go out from Ice Form while being sufficiently hungry ("Hungry" status in my case), the game automatically triggers vampiric weapon wield effect, killing you instantly due to starvation. I'm not sure if this has been considered, but it seems rather harsh and not in line with Crawl's philosophy of preventing player accidents.

Game dump:
http://dobrazupa.org/morgue/Mandevil/morgue-Mandevil-20130405-081026.txt [^]

ttyrec showing the sequence of events:
http://dobrazupa.org/ttyrec/Mandevil/2013-04-05.08:06:22.ttyrec.bz2 [^]
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon iceform-vamp.ttyrec [^] (279,398 bytes) 2013-04-05 10:40

- Relationships
related to 0006389resolvedPleasingFungus Mysterious message when weapons unmeld 
has duplicate 0003783resolvedKiloByte unmelding a vampiric weapon is likely instadeath 

-  Notes
(0022150)
mumra (developer)
2013-04-05 12:25

Ouch. No, we definitely don't want this to happen. Maybe hunger costs shouldn't get applied at all when unmelding vampiric weapons - at the very least there should be a limit to how low it can take your hunger.
(0022153)
Mandevil (reporter)
2013-04-05 16:51

Related bug filing:
https://crawl.develz.org/mantis/view.php?id=6389 [^]
(0022156)
rchandra (reporter)
2013-04-05 20:29

If you don't get distortion unwields, you shouldn't get vampiric wield effects from melding/unmelding.

Also, Contam.
(0022157)
mumra (developer)
2013-04-05 23:43
edited on: 2013-04-05 23:43

It does seem like unmelding a weapon just shouldn't count as "wielding" since effectively you were always wielding the weapon, it had just become part of you for a while.

(0022164)
reid (reporter)
2013-04-06 16:14
edited on: 2013-04-06 16:14

We've been through this before... https://crawl.develz.org/mantis/view.php?id=3783. [^]

(0022165)
mumra (developer)
2013-04-06 18:20

Huh, this would seem to be a regression since 0003783 wss supposed to be fixed.
(0022185)
BlackSheep (reporter)
2013-04-08 17:17

It's fixed for simple vampiric branded weapons, but not for the Vampire's Tooth fixedart. An unmeld parameter was added to that artefact's equip function, but it's not used. Right now it just checks if the player is alive, and if so decrements hunger.
(0022188)
mumra (developer)
2013-04-08 18:53

Fixed in trunk; applied the same check as vampiric weapons, the hunger part is skipped when unmelding.

- Issue History
Date Modified Username Field Change
2013-04-05 10:40 Mandevil New Issue
2013-04-05 10:40 Mandevil File Added: iceform-vamp.ttyrec
2013-04-05 11:43 Mandevil Issue Monitored: Mandevil
2013-04-05 12:25 mumra Note Added: 0022150
2013-04-05 16:51 Mandevil Note Added: 0022153
2013-04-05 20:29 rchandra Note Added: 0022156
2013-04-05 23:41 mumra Relationship added related to 0006389
2013-04-05 23:43 mumra Note Added: 0022157
2013-04-05 23:43 mumra Note Edited: 0022157
2013-04-06 16:14 reid Note Added: 0022164
2013-04-06 16:14 reid Note Edited: 0022164
2013-04-06 18:19 mumra Relationship added has duplicate 0003783
2013-04-06 18:20 mumra Note Added: 0022165
2013-04-08 17:17 BlackSheep Note Added: 0022185
2013-04-08 18:53 mumra Note Added: 0022188
2013-04-08 18:53 mumra Status new => resolved
2013-04-08 18:53 mumra Fixed in Branch => 0.13 development branch
2013-04-08 18:53 mumra Resolution open => done
2013-04-08 18:53 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker