Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005331 [DCSS] Bug Report trivial always 2012-02-18 04:51 2012-03-07 21:08
Reporter XuaXua View Status public  
Assigned To evilmike
Priority normal Resolution no change required Local or Remote Local
Status closed   Operating System Windows
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.11 ancient branch Product Branch 0.11 ancient branch
  Product Version 0.11-a0-175
Summary 0005331: Inconsistent Colors on memorization percentages
Description Step 1: Load XuaXua.cs

Step 2: hit 'M'

Step 3: screenshot.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files png file icon badspelz.png [^] (38,876 bytes) 2012-02-18 04:51


? file icon XuaXua.cs [^] (603,994 bytes) 2012-02-18 04:51

- Relationships

-  Notes
(0017084)
elliptic (developer)
2012-02-18 04:58

You haven't said what is inconsistent, but it looks fine to me. The colors are an indication of how dangerous the spell is to attempt to cast, which depends both on the failure rate and on the level of the spell.
(0017085)
moxian (reporter)
2012-02-18 05:44

Sandblast is at 99% failure, yet it is white, while all other 99%-failure spells are red.
(0017086)
evilmike (developer)
2012-02-18 08:19

There is no inconsistency here.

As elliptic says, the colour represents danger (basically, miscast severity). Sandblast is grey because it's only a level 1 spell, and if you try to cast it nothing bad will happen. Summon scorpions (level 4) is red because if you try to cast it, you have a good chance of killing yourself.

This is documented in the Crawl manual, and is also documented in the changelog. Still, if the distinction isn't clear enough in-game, there's room for improvement on the spell description screen (the one for individual spells), which currently says nothing about danger levels.
(0017210)
XuaXua (reporter)
2012-03-07 21:08

Not sure if you want to open an issue to improve the spell description screen; I'll do so as a separate issue.

- Issue History
Date Modified Username Field Change
2012-02-18 04:51 XuaXua New Issue
2012-02-18 04:51 XuaXua File Added: badspelz.png
2012-02-18 04:51 XuaXua File Added: XuaXua.cs
2012-02-18 04:58 elliptic Note Added: 0017084
2012-02-18 05:44 moxian Note Added: 0017085
2012-02-18 08:19 evilmike Note Added: 0017086
2012-02-18 08:19 evilmike Status new => resolved
2012-02-18 08:19 evilmike Fixed in Branch => 0.11 development branch
2012-02-18 08:19 evilmike Resolution open => no change required
2012-02-18 08:19 evilmike Assigned To => evilmike
2012-03-07 21:08 XuaXua Note Added: 0017210
2012-03-07 21:08 XuaXua Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker