Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002764 [DCSS] Patches minor N/A 2010-10-25 22:31 2010-12-08 11:42
Reporter Arxale View Status public  
Assigned To galehar
Priority normal Resolution done Local or Remote Local
Status resolved   Operating System Windows
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.8 ancient branch Product Branch 0.8 ancient branch
  Product Version
Summary 0002764: Three interface patches
Description There are 3 patches for interface implementables, namely:
https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#more_information_when_missing [^]
https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#more_information_when_mr_is_effective [^]
https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#helpless [^]

For the first two patches threshold numbers between messages was chosen arbitrary. Feel free to adjust them. Also, I want to note that sometimes it is still hard to estimate monster's evasion/to-hit (intended goal), as dispersion of to-hit check is quite high. Maybe rolls should be more averaged or something.

Last patch removes "Helpless, the [foo] fails to dodge..." messages only for cases when you hit monsters (as I don't know how to properly construct "helpless you" message:) ). Also, you will still get a lot of usual "You hit [foo]" (instead of "helpless [foo]") messages, even when target is incapacitated/confused/etc. It is so because initial message was only used in cases when to-hit check passed due to evasion penalty caused by status (not very often) and I kept this logic. Maybe it should not be so.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-More-information-when-missing.patch [^] (8,482 bytes) 2010-10-25 22:31 [Show Content]
? file icon 0002-More-information-when-MR-is-effective.patch [^] (15,268 bytes) 2010-10-25 22:32 [Show Content]
? file icon 0003-Partially-remove-hepless-messages.patch [^] (4,102 bytes) 2010-10-25 22:32 [Show Content]
? file icon 0004-Consistent-messages-for-things-coming-into-view.patch [^] (6,595 bytes) 2010-10-28 14:30 [Show Content]
? file icon 0001-Colours-for-output-of-Ctrl-F.patch [^] (1,063 bytes) 2010-10-31 19:50 [Show Content]
? file icon 0001-Corrosion-resistance-reporting.patch [^] (1,982 bytes) 2010-10-31 19:50 [Show Content]
? file icon 0002-Inscribe-tried-on-foo.patch [^] (5,889 bytes) 2010-10-31 19:51 [Show Content]
? file icon 0003-Autoinscribe-randarts-after-death.patch [^] (903 bytes) 2010-10-31 19:51 [Show Content]
? file icon 0004-Colouring-labyrinth-messages.patch [^] (931 bytes) 2010-10-31 19:51 [Show Content]
? file icon 0005-Show-detailed-costs-of-abilities.patch [^] (4,495 bytes) 2010-11-02 23:19 [Show Content]
? file icon 0006-Colouring-partial-rMut-and-rCorr-yellow.patch [^] (3,870 bytes) 2010-11-02 23:20 [Show Content]
? file icon 0007-Cloak-of-preservation-counts-once-as-rA.patch [^] (751 bytes) 2010-11-02 23:20 [Show Content]
? file icon 0001-More-detailed-corrosion-resistance-reporting.patch [^] (4,833 bytes) 2010-11-12 19:57 [Show Content]
? file icon 0002-Show-detailed-costs-of-abilities-2.patch [^] (3,920 bytes) 2010-11-12 19:57 [Show Content]
? file icon 0004-Add-rAcid-to-resistance-screen.patch [^] (4,852 bytes) 2010-11-26 17:38 [Show Content]

- Relationships

-  Notes
(0009119)
Arxale (reporter)
2010-10-28 14:30

Added another one for:
https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#consistent_messages_for_things_coming_into_view [^]
(0009123)
dpeg (administrator)
2010-10-28 20:34

All of these are awesome. They should go right in.

Comments like those by Arxale should ideally go back onto the wiki. Thanks!
(0009143)
Omndra (reporter)
2010-10-30 20:10

How do I put these into the game?
(where do the files go?)
Or do i have to wait until Devs take your codes and put them into the game.
(0009144)
dpeg (administrator)
2010-10-30 20:31

Omndra: you can apply them yourself, if you want. (This assumes you compile yourself.) However, it shouldn't be long until those patches are pulled into trunk. They are awesome content, it is just a question of a developer looking into them.
(0009160)
Arxale (reporter)
2010-10-31 19:51

And another bunch of small patches for:
1) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#colours_for_output_of_ctrl-f [^]
2) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#corrosion_resistance_reporting [^]
3) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#inscribe_tried_on_foo_instead_of_tried_on_item [^]
 (this one increments TAG_MINOR_VERSION)
4) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#autoinscribe_randarts_after_death [^]
5) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:interface_implementables#highlighting_important_events [^]
 (colouring labyrinth messages)
(0009175)
galehar (administrator)
2010-11-02 10:01

This looks awesome, thanks!
I'll start reviewing and committing them as soon as possible.
(0009181)
Arxale (reporter)
2010-11-02 23:20

Added patches for another two interface ideas:
1) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:ideas#indicate_piety_hunger_costs_of_abilities [^]
It shows more detailed cost of ability in the 'a?' description, with "small/moderate/large/extremely large" ranges for piety and food costs. Ranges numbers was chosen arbitrary. Also, it expands description with additional sentences based on the ability flags (taken from code comments).

2) https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:interface:ideas#pluses_on_menu [^]
It colors rMut and rCorr resistances in yellow if they are partial (i.e. Zin's piety < 180 for rMut, and having rAcid without rCorr for rCorr). Patch also fixes the bug for rCorr, where having four or more sources of rAcid (like yellow drac + preservation + amulet of rCorr) would result in rCorr colored darkgrey. And I noticed another issue. In the player_res_acid() cloak of preservation counts twice - explicitly and as wearing amulet of rCorr, effectively giving rAcid++. I am not sure if it is intended, but if it isn't then last patch fixes it (otherwise just ignore it).
(0009239)
galehar (administrator)
2010-11-08 00:46

I've reviewed and committed the first 3 patches.
For the first one, I removed the damage punctuation. I explained why on the wiki.
For the second one, I just did some rephrasing and added an assertion. I also broke a few lines which were longer than 80 chars.
For the third one, I changed the check so the "helpless" adjective is always put when the monster is helpless, regardless of to_hit roll (as per your comment).
(0009250)
galehar (administrator)
2010-11-09 00:17

I reviewed 3 more:
0004-Consistent-messages-for-things-coming-into-view
This one is awesome. As I said on the wiki, there's still a minor bug with message ordering, but it's already a big improvement. Good work!

0001-Colours-for-output-of-Ctrl-F.patch
This one is ok and is in.

0001-Corrosion-resistance-reporting.patch
This one is wrong. See my comment on the wiki
(0009259)
galehar (administrator)
2010-11-09 15:55

And 3 more:
0002-Inscribe-tried-on-foo.patch (hey, this one was my idea! cool :)
0003-Autoinscribe-randarts-after-death.patch
0004-Colouring-labyrinth-messages.patch

They just work. I didn't change anything.
(0009261)
galehar (administrator)
2010-11-09 23:05

0005-Show-detailed-costs-of-abilities.patch
This one isn't good. If we reduce it to displaying piety cost, it's ok and useful. But the hunger cost needs to be unified with the spell hunger cost scaling (which might need some fixing itself). And the descriptions for flags:
some are useless (It is a breathing attack).
others can be very useful but phrasing is meaningless (Ability has its own piety cost, Ability has its own delay).
some are redundant (Ability requires fruit).
(0009271)
Arxale (reporter)
2010-11-12 20:03

I updated corrosion resistance patch and abilities' costs patch (according to wiki). I will probably do "showing rAcid" thing next (and can do rMut, if you come to final agreement on how it should be displayed), but where on % screen it should go? Expand the list by one more line or merge some existing lines together?
(0009277)
TGW (reporter)
2010-11-14 16:22

Posting here because someone removed the section from the wiki.

The "inscribe tried on foo" one is unnecessarily verbose and can hide the item weight or the player's inscriptions. It actually only needs to show a few things:
1) Whether the item was identified.
2) Whether the item was an armour at less than maximum enchantment, and what the armour's enchantment was.
3) Whether the item was a wand.
(0009280)
galehar (administrator)
2010-11-15 11:30

tgw: I removed the wiki section because it was done, but you're free to bring it back if you want to comment on this.

The fact that a long inscription can hide weight is a separate issue. Hiding player inscriptions seems very minor. This change is about you not having to inscribe the scrolls you're trying to identify after all.

I like that it only provides the name of the item you tried it on. It's up to you to use this information to deduce what it could be or not. For experienced players it's trivial of course, but we don't want to spoil new players by giving away the rules of the id minigame.
(0009282)
OG17 (reporter)
2010-11-15 14:55

Crawl endorses spoilers now?
(0009287)
galehar (administrator)
2010-11-15 22:53

New versions of corrosion resistance (with the changes I talked about on the wiki) and cost display for abilities are in.
(0009288)
galehar (administrator)
2010-11-15 22:55

tgw: I fixed the "tried on foo" to make it not include "tried" and "zapped" strings or any inscription. So it is less likely to override the weight display now.
(0009400)
Arxale (reporter)
2010-11-26 17:43

Last patch add "rAcid" line to the resistances screen. Spirit.Shd was moved to the second column, and Rnd.Telep was merged with Stasis/Prev.Telep.
Patch does not include previous changes, so rCorr will still work incorrectly if you apply just this one.
(0009546)
galehar (administrator)
2010-12-03 23:46

I just commited the rAcid patch.
(0009590)
jpeg (manager)
2010-12-06 00:29

I've lost track of which of these patches (if any) are still under revision/discussion. Could someone more knowledgeable please sum up the current status, or hopefully close this tracker item?

@Arxale: Please submit new patches to new issues. Also, I've added you to the credits, using your user name, as requested.
(0009627)
galehar (administrator)
2010-12-08 11:42

All the patches have been reviewed and commited.

- Issue History
Date Modified Username Field Change
2010-10-25 22:31 Arxale New Issue
2010-10-25 22:31 Arxale File Added: 0001-More-information-when-missing.patch
2010-10-25 22:32 Arxale File Added: 0002-More-information-when-MR-is-effective.patch
2010-10-25 22:32 Arxale File Added: 0003-Partially-remove-hepless-messages.patch
2010-10-28 14:30 Arxale File Added: 0004-Consistent-messages-for-things-coming-into-view.patch
2010-10-28 14:30 Arxale Note Added: 0009119
2010-10-28 20:34 dpeg Note Added: 0009123
2010-10-28 20:34 dpeg Status new => acknowledged
2010-10-30 20:10 Omndra Note Added: 0009143
2010-10-30 20:31 dpeg Note Added: 0009144
2010-10-31 19:50 Arxale File Added: 0001-Colours-for-output-of-Ctrl-F.patch
2010-10-31 19:50 Arxale File Added: 0001-Corrosion-resistance-reporting.patch
2010-10-31 19:51 Arxale File Added: 0002-Inscribe-tried-on-foo.patch
2010-10-31 19:51 Arxale File Added: 0003-Autoinscribe-randarts-after-death.patch
2010-10-31 19:51 Arxale File Added: 0004-Colouring-labyrinth-messages.patch
2010-10-31 19:51 Arxale Note Added: 0009160
2010-11-02 10:01 galehar Note Added: 0009175
2010-11-02 23:19 Arxale File Added: 0005-Show-detailed-costs-of-abilities.patch
2010-11-02 23:20 Arxale File Added: 0006-Colouring-partial-rMut-and-rCorr-yellow.patch
2010-11-02 23:20 Arxale File Added: 0007-Cloak-of-preservation-counts-once-as-rA.patch
2010-11-02 23:20 Arxale Note Added: 0009181
2010-11-07 00:31 galehar Assigned To => galehar
2010-11-07 00:31 galehar Status acknowledged => assigned
2010-11-08 00:46 galehar Note Added: 0009239
2010-11-09 00:17 galehar Note Added: 0009250
2010-11-09 15:55 galehar Note Added: 0009259
2010-11-09 23:05 galehar Note Added: 0009261
2010-11-12 19:57 Arxale File Added: 0001-More-detailed-corrosion-resistance-reporting.patch
2010-11-12 19:57 Arxale File Added: 0002-Show-detailed-costs-of-abilities-2.patch
2010-11-12 20:03 Arxale Note Added: 0009271
2010-11-14 16:22 TGW Note Added: 0009277
2010-11-15 11:30 galehar Note Added: 0009280
2010-11-15 14:55 OG17 Note Added: 0009282
2010-11-15 22:53 galehar Note Added: 0009287
2010-11-15 22:55 galehar Note Added: 0009288
2010-11-26 17:38 Arxale File Added: 0004-Add-rAcid-to-resistance-screen.patch
2010-11-26 17:43 Arxale Note Added: 0009400
2010-12-03 23:46 galehar Note Added: 0009546
2010-12-06 00:29 jpeg Note Added: 0009590
2010-12-08 11:42 galehar Note Added: 0009627
2010-12-08 11:42 galehar Status assigned => resolved
2010-12-08 11:42 galehar Fixed in Branch => 0.8 development branch
2010-12-08 11:42 galehar Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker