Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0012029 [DCSS] Bug Report minor have not tried 2019-07-18 19:55 2020-04-06 18:18
Reporter Yermak View Status public  
Assigned To Reaver
Priority normal Resolution reopened Local or Remote Remote
Status new   Operating System Online
Projection none   Console or Tiles WebTiles
ETA none Fixed in Branch 0.24 old branch Product Branch 0.24 old branch
  Product Version
Summary 0012029: Artefact jewellery is sometimes not on autopickup (depends on base type).
Description E.g. switching amulet of reflection off autopickup also switches off artefact amulets which base type is reflection.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0033352)
Reaver (developer)
2019-07-19 04:50
edited on: 2019-07-19 04:53

This should be fixed as of commit a1643a678889

Thank you for your report!

(0033687)
Yermak (reporter)
2020-02-20 08:27

This bug was fixed only partially. It still presents in cases where jewellery base type is protection or evasion (reflection, too, probably) and you switched plain rings of corresponding type off autopickup. E.g. not only you will not pick up rings of Phasing or Robustness, but also random artefacts like a ring "Jesch" {AC+5 Dex+4} in my current game.
(0033745)
elliptic (developer)
2020-04-06 18:18

Also stealth, since autopickup failed to pick up the ring "Leatu" {rPois Str+4 Dex+3 Stlth+} for me (base type ring of stealth).

- Issue History
Date Modified Username Field Change
2019-07-18 19:55 Yermak New Issue
2019-07-19 04:50 Reaver Note Added: 0033352
2019-07-19 04:50 Reaver Status new => resolved
2019-07-19 04:50 Reaver Fixed in Branch => 0.24 development branch
2019-07-19 04:50 Reaver Resolution open => done
2019-07-19 04:50 Reaver Assigned To => Reaver
2019-07-19 04:53 Reaver Note Edited: 0033352
2019-08-03 16:59 Yermak Status resolved => closed
2020-02-20 08:27 Yermak Note Added: 0033687
2020-02-20 08:27 Yermak Status closed => new
2020-02-20 08:27 Yermak Resolution done => reopened
2020-04-06 18:18 elliptic Note Added: 0033745


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker