Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011268 [DCSS] Patches minor have not tried 2017-10-26 06:28 2018-05-08 05:18
Reporter Implojin View Status public  
Assigned To advil
Priority normal Resolution done Local or Remote Local
Status resolved   Operating System Windows
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.22 old branch Product Branch longterm development (0.25+)
  Product Version
Summary 0011268: Fix for broken mingw-w64 tiles compiling.
Description Updated versions of mingw-w64 are unable to compile local tiles, due to an incompatibility semi-recently introduced there with our (outdated) SDL2 headers.

There are a couple of fixes extant on SDL2's bug tracker, one of which has already been rolled into SDL2's hg repo.

The below pull request fixes tiles compiles under mingw-w64 (both i686 and x86_64 toolchains) with a kludgy-but-simple check for mingw-w64 and its GCC version.

https://github.com/crawl/crawl-sdl2/pull/1 [^]

This PR fixes this mantis issue:
https://crawl.develz.org/mantis/view.php?id=11134 [^]
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032230)
advil (administrator)
2018-05-08 05:18

I'm marking this resolved because of https://github.com/crawl/crawl-sdl2/commit/9e90bf424d2312659191a2789d88c08db2dc8e78 [^]

However, on reflection I'm not sure that your change covers exactly the same cases as mine (I was targeting msys2 specifically), so feel free to comment if it doesn't and I'll reopen.

- Issue History
Date Modified Username Field Change
2017-10-26 06:28 Implojin New Issue
2018-05-08 05:18 advil Note Added: 0032230
2018-05-08 05:18 advil Status new => resolved
2018-05-08 05:18 advil Fixed in Branch => 0.22 development branch
2018-05-08 05:18 advil Resolution open => done
2018-05-08 05:18 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker