Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010637 [DCSS] Bug Report trivial always 2016-08-29 00:48 2021-03-03 08:12
Reporter Nekoatl View Status public  
Assigned To advil
Priority normal Resolution done Local or Remote Local
Status closed   Operating System Windows
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.26 stable branch Product Branch 0.19 ancient branch
  Product Version 0.19-a0-1260-gc94d3f7
Summary 0010637: Renounce Religion not assigning to hotkey 'X'
Description When joining a religion with starting piety (either from playing a monk or using an Ecumenical Altar), the Renounce Religion ability is not getting assigned to the hotkey 'X' as it does when joining a religion without starting piety. This can be easily observed by creating a human monk and using Wizard mode to become a worshiper of Okawaru.

I'm playing the tiles version from http://crawl.develz.org/trunk/ [^] in in Windows 10.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030941)
PleasingFungus (administrator)
2016-08-29 17:27

I haven't tested yet, but this may be caused by 2a379a6b1d42a .
(0031144)
PleasingFungus (administrator)
2016-10-20 07:47

Can't reproduce this. Is this still happening for you?
(0031148)
Nekoatl (reporter)
2016-10-20 08:02

Yes, but upon further testing, it seems to only happen when the starting piety grants an additional divine ability. When starting a human monk and using wizard mode to join Sif Muna or Okawaru, Renounce Religion does not get mapped to X, but when joining Nemelex Xobeh, it does.
(0033929)
Nekoatl (reporter)
2020-11-18 20:41

I haven't seen this happen in quite some time and can no longer reproduce the behavior intentionally. I think the bug has been fixed.
(0033997)
advil (administrator)
2020-12-22 03:25

This bug has still been lurking in the codebase; I believe it could happen any time `your_talents` was triggered in the middle of `join_religion` with a god that had 0-piety abilities; this call ordering was possible because over time there have been various ways it could be called as an indirect side-effect of messaging. I suspect the original version of this must have been local-tiles only, where a badly timed more on joining a religion would cause a redraw, and build the abilities list (using your_talents), before the god was fully set up. Quivers introduced a new version of this that made it easier to track down

Fixed, hopefully, in: https://github.com/crawl/crawl/commit/5b34608550e9 [^]

- Issue History
Date Modified Username Field Change
2016-08-29 00:48 Nekoatl New Issue
2016-08-29 17:27 PleasingFungus Note Added: 0030941
2016-10-20 07:47 PleasingFungus Note Added: 0031144
2016-10-20 08:02 Nekoatl Note Added: 0031148
2020-11-18 20:41 Nekoatl Note Added: 0033929
2020-12-22 03:25 advil Note Added: 0033997
2020-12-22 03:25 advil Status new => resolved
2020-12-22 03:25 advil Fixed in Branch => 0.26 development version
2020-12-22 03:25 advil Resolution open => done
2020-12-22 03:25 advil Assigned To => advil
2021-03-03 08:12 Nekoatl Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker