Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010295 [DCSS] Bug Report minor have not tried 2016-02-21 22:49 2016-07-05 08:41
Reporter crate View Status public  
Assigned To PleasingFungus
Priority normal Resolution done Local or Remote Remote
Status closed   Operating System CAO
Projection none   Console or Tiles Console
ETA none Fixed in Branch 0.18 ancient branch Product Branch 0.18 ancient branch
  Product Version 0.18-a0-1468-g4d15c65
Summary 0010295: Warlock's mirror reflects acid but I get corroded anyway
Description  The deep elf sorcerer casts a spell at you.
 Your +3 warlock's mirror {reflect} reflects the bolt of acid!
 The acid corrodes you!
 The bolt of acid hits the deep elf sorcerer.
 The acid corrodes the deep elf sorcerer!

I don't think I'm supposed to get corroded when the acid didn't really hit me.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030209)
PleasingFungus (administrator)
2016-02-23 01:09
edited on: 2016-02-23 01:15

This is intentional, not specific to the warlock's mirror [applies to any shield that blocks reflects a projectile - ref 4b9db609dced]. It was added on the reasoning that a shield that reflect acid is still getting hit by the acid, so corrosion applying Makes Sense.

Leaving this open because I'm not sure whether the behavior should be retained.

(0030210)
crate (reporter)
2016-02-23 15:40

Shields don't give AC, and the most of the player it could be hitting is the shield (since it doesn't do damage or anything). So reducing player AC doesn't Make Sense.

If it reduced SH then that could Make Sense, but corr doesn't reduce SH.
(0030211)
PleasingFungus (administrator)
2016-02-25 02:43

Yeah, agreed. Fixed in dd1e41a.

- Issue History
Date Modified Username Field Change
2016-02-21 22:49 crate New Issue
2016-02-23 01:09 PleasingFungus Note Added: 0030209
2016-02-23 01:15 PleasingFungus Note Edited: 0030209
2016-02-23 01:15 PleasingFungus Note Edited: 0030209
2016-02-23 15:40 crate Note Added: 0030210
2016-02-25 02:43 PleasingFungus Note Added: 0030211
2016-02-25 02:43 PleasingFungus Status new => resolved
2016-02-25 02:43 PleasingFungus Fixed in Branch => 0.18 development branch
2016-02-25 02:43 PleasingFungus Resolution open => done
2016-02-25 02:43 PleasingFungus Assigned To => PleasingFungus
2016-07-05 08:41 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker